Back to overview
Degraded

File uploading issue

Sep 12 at 09:30am UTC
Affected services
Workhub24 UI (app.workhub24.com)
Beta Workhub24 UI (beta.workhub24.com)

Resolved
Sep 12 at 01:30pm UTC

We’ve routed file uploads through the AWS edge network, and the issue is now resolved.

Created
Sep 12 at 09:30am UTC

Due to an undersea cable cut near the Red Sea, customers in Asia may experience slowness or failures when uploading files. We are working on a solution.