Back to overview
Degraded

We're experiencing slower task completion times due to temporary system degradation. Our team is investigating. Thank you for your patience.

Jul 31 at 03:26am UTC
Affected services
Workhub24 API (app.workhub24.com)

Resolved
Jul 31 at 07:15am UTC

The issue causing task delays has been identified and fixed. We've also enhanced monitoring to catch such issues earlier. Thank you for your understanding.

Created
Jul 31 at 03:26am UTC

We are experiencing a slowness in our task module.