Back to overview
Degraded

Platform-Wide Service Disruption Due to Database Provider Issue

May 7, 2026 at 3:19am UTC
Affected services
Authentication
Workhub24 API (app.workhub24.com)
Beta Workhub24 UI (beta.workhub24.com)
Beta Workhub24 API (beta.workhub24.com)
Portal Workhub24 API (portal.workhub24.com)

Resolved
May 7, 2026 at 6:43am UTC

The incident was caused by an unexpected connection issue with our managed NoSQL database infrastructure, which led to temporary service instability. Due to queued and delayed processes during the affected period, the platform required additional time to fully recover after the fix was applied

All services have been restored and are currently under close monitoring.

Created
May 7, 2026 at 3:19am UTC

We are currently experiencing an issue with our managed database provider, which is impacting all customers on our platform. Our team is actively investigating the issue and working to restore full service as quickly as possible.