Back to overview
Degraded
Outbound emails are not working
Jun 04 at 11:18am UTC
Affected services
Workhub24 Email Service
Resolved
Jun 04 at 11:32am UTC
We have switched to our secondary email provider and outbound emails are working back again.
Affected services
Created
Jun 04 at 11:18am UTC
We've identified an issue where outbound emails are not working. We are working with our Email service provider to resolve the issue.
Affected services