Back to overview
Degraded

Default Values Not Saved During Card Creation

Nov 20 at 04:46am UTC
Affected services
Workhub24 UI (app.workhub24.com)
Workhub24 API (app.workhub24.com)

Resolved
Nov 20 at 08:30am UTC

Impact:

This issue affected workflows relying on default values during card creation. Due to a bug, default values were not sent from the front end to the backend, resulting in incomplete or inaccurate data being stored in the affected cards.

Root Cause:

A frontend bug in the system failed to include default values in the payload during card creation.

Resolution:

  • A fix was developed and deployed to production.
  • Since this is a frontend code change, the fix will take effect only when users reload their browser page to download the updated code.

Mitigation Steps:

  1. The frontend bug was identified and resolved.
  2. The fix was tested in staging before deployment.
  3. All users were logged out system-wide one hour post-deployment to prompt a code refresh.
  4. Customers experiencing the issue are advised to reload their browser page to ensure they receive the updated code.
  5. An impact analysis is underway to identify affected workflows.
  6. Impacted customers will be notified individually, and appropriate remediation will be provided.

Next Steps:

  1. Conduct a comprehensive review of the testing pipeline to ensure similar issues are detected earlier.
  2. Introduce automated testing for scenarios involving default values during card creation.
  3. Enhance monitoring and alerting for anomalies in data submissions.
  4. Provide a detailed follow-up report to affected customers.

Customer Communication:

An email explaining the issue, its resolution, and the mitigation steps has been sent to all customers. Customers experiencing this issue are instructed to reload their browser page to ensure they receive the updated code. Impacted customers will be contacted directly.

Additional Notes:

The team is committed to preventing similar issues in the future and ensuring the platform's reliability for all users.

Created
Nov 20 at 04:46am UTC

This issue affected workflows relying on default values during card creation. Due to a bug, default values were not sent from the front end to the backend, resulting in incomplete or inaccurate data being stored in the affected cards.